Issue with inviting users

Incident Report for Port

Resolved

This incident has been resolved.
Posted Nov 25, 2025 - 13:50 UTC

Update

We are continuing to monitor for any further issues.
Posted Nov 25, 2025 - 13:42 UTC

Monitoring

A fix has been released, and invites are now working again.
We are monitoring the system functionality.
Posted Nov 25, 2025 - 13:42 UTC

Identified

We have identified an issue which affects user invites, and are working on a fix.This issue is affecting both Port regions.
The system API and all services continue to operate normally.
We will provide more updates as we have them.
Posted Nov 25, 2025 - 13:35 UTC
This incident affected: EU (Emails and Notifications) and US (Emails and Notifications).