Actions and automations infrastructure upgrade

Scheduled for Jun 14, 10:30 - 15:30 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Jun 07, 2026 - 05:49 UTC

Scheduled

Some slowness may be observed during this time
Posted Jun 14, 2026 - 09:00 UTC
This scheduled maintenance affects: EU (Self-Service Actions, Automations), US (Self-Service Actions, Automations), and GitHub Actions.