[EU] Delay in global search queries

Incident Report for Port

Update

Entity updates from early last week (6-7.07) will now be available in the global search, we are currently working to expedite the process.
Posted Jul 14, 2025 - 15:51 UTC

Identified

We have identified an issue with global search for new entities, at the moment global search for new entities might experience longer than usual delay until the search successfully returns the new entities as results.

Note that the fix is performed as part of a long-running background process, we will update when the issue has been resolved and all new entities are searchable using global search.
Posted Jul 10, 2025 - 15:50 UTC
This incident affects: EU (UI Global Entities Search).