Intermittent AI feature failures in EU region

Incident Report for Port

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 11:10 UTC

Identified

We are experiencing intermittent issues with AI-powered features in the EU region, including the AI assistant and AI workflow nodes. Some requests may fail or time out. The issue has been traced to our upstream AI infrastructure provider, and we have opened a support case with them. We are actively investigating and will provide updates as we learn more.
Posted Mar 24, 2026 - 12:10 UTC
This incident affected: EU (AI).