Issue triggering self-service actions in UI mode

Incident Report for Port

Resolved

We have confirmed that no self-service action trigger attempts from the UI mode are experiencing any unusual issues, and the issue has been resolved
Posted Jun 23, 2025 - 19:32 UTC

Monitoring

We performed a revert of recent changes made to the self-service actions UI form.

The issues described as part of this event should no longer be experienced by users, but we are still monitoring to validate that no further issues occur.
Posted Jun 23, 2025 - 19:18 UTC

Investigating

We are currently investigating an issue preventing the trigger of self-service actions in some instances when using the UI mode of the form.

We have currently identified this can happen in one of the following cases:
- When an action has invisible inputs which depend on other inputs.
- When an action uses unique sorting of the inputs in the action's UI form.

We are currently working on a fix for this issue.

Until the issue is fixed, it is possible to switch to JSON mode to trigger the self-service action as usual.

We will update once the issue is fixed.
Posted Jun 23, 2025 - 15:40 UTC
This incident affected: EU (Self-Service Actions) and US (Self-Service Actions).