The maintenance has been completed. We are verifying the system stability.
Posted Mar 15, 2026 - 10:22 UTC
Update
EU is now in read only. We will provide an update when the region is back to fully operational mode.
Posted Mar 15, 2026 - 10:09 UTC
Update
The maintenance has been completed in US, and the system is back to operational mode. EU will enter a read only in 5 minutes.
Posted Mar 15, 2026 - 09:52 UTC
Update
The US region is now entering read only mode.
Posted Mar 15, 2026 - 09:19 UTC
Update
The US region will enter read only in 5 minutes to initiate the maintenance. We will provide more updates during the maintenance.
Posted Mar 15, 2026 - 09:09 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 15, 2026 - 09:00 UTC
Update
We're performing a scheduled maintenance to upgrade our database infrastructure. This will improve platform reliability and performance.
During this time, certain functionalities of the system will enter a temporarily read only mode. The following will be temporarily unavailable: * Creating or updating users, teams, roles, or permissions * New user sign-ups or first-time logins * Creating or modifying blueprints, pages, actions, or integrations * SSO and SCIM configuration changes (events will be queued and processed after maintenance)
Entities operations and actions invocations will continue to work as expected during this maintenance.
We will be providing live updates about the read-only phase during the maintenance. No action required. All functionality will be fully restored once the maintenance is complete.
Posted Mar 03, 2026 - 17:54 UTC
Scheduled
We will be performing a maintenance to our backend components. During this time management operations will be temporarily unavailable, including user updates. Entities operations and API access will remain available. We will provide more information on this maintenance as it becomes available.
Posted Mar 02, 2026 - 05:24 UTC
This scheduled maintenance affected: EU (RBAC) and US (RBAC).