Action status report degraded

Incident Report for Port

Resolved

Action statuses for Github action runs during the incident have been restored.
Posted Apr 03, 2025 - 19:50 IDT

Monitoring

We resolved the issue causing the failures when updating action statuses. Now we will go over the failed status updates and update them accordingly.
Posted Apr 02, 2025 - 17:57 IDT

Identified

We are continuing to see issues with updating action run statuses. We are continuing investigations and will continue updating.

The issue has been identified to be contained to Github action runs. The issue is only with status updates, and not with the invocation itself.
Posted Apr 02, 2025 - 14:33 IDT

Monitoring

A fix has been implemented and action runs are reporting run statuses.
We are monitoring to make sure everything is working as intended, and are working on restoring missing status updates.
Posted Apr 02, 2025 - 13:54 IDT

Investigating

We are investigating an issue with failures for updating action run statuses. The incident does not have effect on action triggers themselves.
Posted Apr 02, 2025 - 13:31 IDT
This incident affected: EU (Self-Service Actions).